Как исправить ошибку при обновлении в Cydia

Джейлбрейк, Новости

В последнее время многие пользователи жалуются на ошибки при обновлении списка твиков в Cydia. Последний раз большой всплеск активности в магазине твиков наблюдался после появления утилиты для джейлбрейка Evasi0n. Тогда при попытке обновить базу твиков можно было увидеть ошибки «HTTP/1.1 404 Not Found» и «Hash Sum mismatch». Сейчас ситуация с Cydia стабилизировалась, однако, 

при обновлении можно наткнуться на проблемы описанные следующим сообщением: «wow, you exceeded the number of package names this APT is capable of».

cydia wow you exceeded fix

Данная ошибка связана исключительно с техническими особенностями самой Cydia. Утилита способна обрабатывать до 60 000 пакетов с твиками и расширениями. Такой лимит был установлен разработчиком после примерного подсчета твиков в стандартных репозиториях, но в последнее время стали появляться сторонние сайты со взломанными или доработанными твиками. Они и превышают лимит пакетов в Cydia. Таким образом, чтобы избавиться от подобной ошибки, следует удалить 1-2 ненужных пиратских репозитория.

Для этого следует зайти в Cydia, перейти на вкладку Manage (Изменить) –> Sources (Источники) –> Edit (Изменить). Из списка репозиториев просто удаляем ненужные источники. Обязательно стоит оставить стандартные BigBoss, Dev Team, ModMyI и ZodTTD. Ошибка при обновлении после этого пропадет.

Так же читайте:
Что такое репозитории и зачем они нужны.
Подробное описание Cydia.
Что делать после джейлбрейка iPhone и iPad.

Пожалуйста, оцените статью

Средняя оценка / 5. Количество оценок:

Оценок пока нет. Поставьте оценку первым.